Microsoft Excel

трюкиприёмырешения

Примеры формул
10.04.2013 1345

Как искать значения в таблице Excel при помощи массива

Если ваша таблица для поиска маленькая, вы могли бы избежать ее использования и хранить информацию поиска в массиве. В этой статье описаны типичные проблемы поиска с применением стандартной таблицы и альтернативный метод с использованием массива.

Использование таблицы поиска

На рис. 123.1 показана таблица с результатами студентов по тесту. Диапазон E2:F6 (названный Градация) отображает таблицу поиска, применяемую для назначения оценки (в виде буквы) в соответствии с числовым результатом теста.

Рис. 123.1. Таблица для поиска оценки по результатам теста

Рис. 123.1. Таблица для поиска оценки по результатам теста

Столбец С содержит формулы, которые используют функцию ВПР, и таблицу поиска для назначения оценки на основании результата из столбца В. Формула в С2, например, такая:
=ВПР(B2;Градация;2)

Применение массива

Когда таблица поиска мала (как в данном примере), вы можете задействовать вместо нее массив. Это поможет устранить беспорядок в исходной таблице. Следующая формула, например, возвращает оценку без использования таблицы. Информация из таблицы поиска кодируется в массив констант. Обратите внимание на фигурные скобки для указания массива, а также точки с запятой для разделения строк:
=ВПР(B2;{0;"F":40;"D":70;"C":80;"B":90;"A"};2)

Другой подход предлагает более разборчивую формулу и заключается в использовании функции ВПР с двумя аргументами массивов:
=ПРОСМОТР(B2;{0;40;70;80;90};{"F";"D";"C";"B";"A"})

Предыдущие формулы используют массивы в качестве аргументов, но не являются формулами массивов. Таким образом, вам не нужно нажимать Ctrl+Shift+Enter при вводе этих формул.

Top