Microsoft Excel

трюкиприёмырешения

Как в Excel удалить избыточные пробелы

Многие ошибки возникают из-за того, что вы даже не можете увидеть: из-за пробела. Рассмотрим пример, показанный на рис. 198.1. Ячейка В2 содержит формулу, которая ищет название цвета в ячейке В1 и возвращает соответствующий код из таблицы: =ВПР(B1;D2:E9;2;ЛОЖЬ).

Рис. 198.1. Простая формула поиска возвращает код цвета, введенного в ячейку В1

Рис. 198.1. Простая формула поиска возвращает код цвета, введенного в ячейку В1

На рис. 198.2 формула в ячейке В2 возвращает ошибку указывающую на то, что красный не был найден в таблице. Тысячи пользователей Excel потратили бы уйму времени, пытаясь выяснить, почему так произошло. В данном случае ответ прост: ячейка D7 не содержит слово Красный. Точнее, она содержит слово Красный, за которым идет пробел. Для Excel эти строки совершенно разные.

Рис. 198.2. Формула поиска не может найти слово Красный в таблице

Рис. 198.2. Формула поиска не может найти слово Красный в таблице

Если лист содержит тысячи текстовых записей и вам необходимо выполнить сравнение, то сначала нужно найти ячейки, которые содержат избыточные пробелы, а затем исправить их. Термин «избыточный пробел» означает текстовую запись, которая содержит что-нибудь из следующего набора: один или несколько пробелов в начале, один или несколько пробелов в конце либо от двух идущих вместе пробелов.

Один из способов идентификации этого типа ячеек заключается в применении условного форматирования. Чтобы задать условное форматирование, выполните следующие действия.

  1. Выделите все текстовые ячейки, к которым нужно применить условное форматирование.
  2. Выберите Главная ► Стили ► Условное форматирование ► Создать правило для открытия диалогового окна Создание правила форматирования.
  3. В верхней части окна выберите пункт Использовать формулу для определения форматирующих ячеек.
  4. Введите формулу, аналогичную следующей, в нижней части диалогового окна: =А1<>СЖПРОБЕЛЫ(А1). Заметьте: здесь предполагается, что ячейка А1 является верхней левой ячейкой в выделенном фрагменте. Если это не так, замените адрес верхней левой ячейки для набора ячеек, которые вы выбрали в шаге 1.
  5. Нажмите кнопку Формат для открытия окна Формат ячеек и выберите тип форматирования для ячеек, содержащих избыточные пробелы. Например, задайте выделение желтым цветом.
  6. Нажмите кнопку ОК, чтобы закрыть окно Формат ячеек, и снова нажмите ОК, чтобы закрыть окно Создание правила форматирования.

После выполнения этих шагов каждая ячейка, которая содержит избыточные пробелы и находится в пределах выбранного в шаге 1 диапазона, будет отформатирована по вашему выбору. Вы можете легко определить эти ячейки и удалить пробелы.

Из-за особенностей работы функции СЖПРОБЕЛЫ формула в шаге 4 также применяет условное форматирование ко всем числовым ячейкам. Вот немного более сложная формула, которая не применяет форматирование к числовым ячейкам: =ЕСЛИ(НЕ(ЕНЕТЕКСТ(А1));А1<>СЖПРОБЕЛЫ(А1))

В учебном пособии ярошевский история психологии рассматривается становление и развитие мировой и российской психологии, предлагаются разнообразные практические и тестовые задания, тексты ятя дополнительного чтения. Работа с этим материалом позволит расширить представления о психологических концепциях и идеях разных исторических периодов, проверить степень их понимания.


Top