Microsoft Excel

трюкиприёмырешения

Примеры формул
07.04.2013 6042

Как в Excel преобразовать дюймы в футы и дюймы

Если вам когда-нибудь понадобится преобразовать дюймы в футы и дюймы, вы быстро поймете достоинства метрической системы. Преобразование дюймов в футы и дюймы является, по существу, задачей деления, в которой необходимо обратить внимание на остаток (оставшиеся дюймы).

Следующая формула предполагает, что ячейка А2 содержит значение, представляющее дюймы. Формула отображает результат в футах и дюймах (например, если А2 содержит значение 43, результат будет 3’7"): =ТЕКСТ(ЦЕЛОЕ(A2/12);"#;#0")&"' "&ОСТАТ(A2; 12)&"""".

Эта формула возвращает текстовую строку, поэтому вы не можете выполнять математические операции над полученным результатом. Если вы хотите преобразовать текстовую строку с футами и дюймами обратно в дюймы, то следующая формула выполнит эту задачу (предполагается, что ячейка В2 содержит строку, наподобие 9’11"):
=(ЛЕВСИМВ(B2;НАЙТИ("'";B2)-1)+((ПСТР(B2;НАЙТИ("'";B2)+1;ДЛСТР(B2)-НАЙТИ("'";B2)-1))/12))*12.

Эти формулы работают только с положительными значениями дюймов.

На рис. 99.1 показаны результаты выполнения описанных формул.

Рис. 99.1. Преобразование дюймов в футы и дюймы, а затем обратно в дюймы

Рис. 99.1. Преобразование дюймов в футы и дюймы, а затем обратно в дюймы


Top