Microsoft Excel

трюкиприёмырешения

Примеры формул
10.04.2013 4787

Как в таблицах Excel использовать функцию ДВССЫЛ

Чтобы сделать формулу более гибкой, для создания ссылки на диапазон вы можете воспользоваться функцией ДВССЫЛ. Эта редко используемая функция принимает текстовый аргумент, который напоминает ссылку на диапазон, а затем преобразует его в фактическую ссылку на диапазон. Когда вы поймете, как работает эта функция, вы сможете применять ее для создания более мощных интерактивных электронных таблиц.

Косвенное указание строк

На рис. 124.1 показан пример использования функции ДВССЫЛ. Формула Е5 будет следующей:
=СУММ(ДВССЫЛ("B"&E2&":B"&E3))

Рис. 124.1. Для суммирования предоставленных пользователем строк применяется функция

Рис. 124.1. Для суммирования предоставленных пользователем строк применяется функция

Обратите внимание, что в аргументе функции ДВССЫЛ указан оператор конкатенации. Он позволяет создать ссылку на диапазон, используя значения в ячейках Е2 и Е3. Таким образом, если Е2 содержит 2, а Е3 содержит 4, ссылка на диапазон получается идентичной этой строке: "В2:В4".

Функция ДВССЫЛ преобразует строку в фактическую ссылку на диапазон, которая затем передается функции СУММ. В сущности, формула возвращает: =СУММ(В2:В4). При изменении значений в Е2 и Е3 формула обновляется и отображает суммы указанных строк.

Косвенное указание названий листов

На рис. 124.2 продемонстрирован другой пример — на этот раз применятся ссылка на лист. Столбец А листа Итого содержит текст, который соответствует другим листам книги. Столбец В содержит формулы, которые ссылаются на эти пункты текста. Например, формула в ячейке В2 следующая:
=СУММ(ДВССЫЛ(A2&"!F1:F10")).

Рис. 124.2. Столбец А листа Итого содержит текст, который соответствует другим листам книги

Рис. 124.2. Столбец А листа Итого содержит текст, который соответствует другим листам книги

Эта формула объединяет текст в А2 со ссылкой на диапазон. Функция ДВССЫЛ вычисляет результат и преобразует его в фактическую ссылку на диапазон. Результат эквивалентен следующей формуле:
=СУММ(Север!F1:F10).

Формула копируется вниз по столбцу. Каждая формула возвращает сумму диапазона F1:F10 соответствующего листа.

Создание неизменной ссылки на ячейку

Другое применение функции ДВССЫЛ состоит в том, чтобы создать такую ссылку на ячейку, которая никогда не изменяется. Для примера рассмотрим формулу, которая суммирует значения в первых 12 строках столбца А: =СУММ(А1:А12).

Если вставить новую строку 1, Excel изменит формулу на такую: =СУММ(А2:А13). Другими словами, формула подстраивается так, чтобы по-прежнему ссылаться на исходные данные (и она уже не суммирует первые 12 строк столбца А).

Чтобы предотвратить Excel от изменения ссылок на ячейки, используйте функцию ДВССЫЛ: =СУММ(ДВССЫЛ("А1:А12")). Эта формула всегда возвращает сумму первых 12 строк в столбце А.


Top