Microsoft Excel

трюкиприёмырешения

Примеры формул
07.04.2013 3536

Как подсчитать недублированные записи в диапазоне таблицы Excel

В некоторых ситуациях может потребоваться подсчитать количество сдублированных записей в диапазоне (рис. 117.1). В столбце А есть список животных, а цель заключается в подсчете количества различных животных в списке.

Формула в ячейке В2 возвращает 8, что соответствует количеству недублированных животных. Эта формула (кстати, формула массива) следующая: =СУММ(1/СЧЁТЕСЛИ(A1:A10;A1:A10)). Формула считается классической — о ней упоминают на различных сайтах и в новостных группах. Эта заслуга принадлежит Дэвиду Хагеру (David Hager), который первым придумал формулу.

При вводе формулы массива нажмите Ctrl+Shift+Enter (а не просто Enter). Excel окружит формулу фигурными скобками, напоминая вам, что это формула массива.

Рис. 117.1. Для подсчета количества недублированных записей в диапазоне можно использовать формулу массива

Рис. 117.1. Для подсчета количества недублированных записей в диапазоне можно использовать формулу массива

Предыдущая формула массива прекрасно работает, пока диапазон не содержит одну или несколько пустых ячеек. Следующая усовершенствованная версия этой формулы массива использует новую функцию ЕСЛИОШИБКА для решения возможной проблемы:
=СУММ(ЕСЛИОШИБКА(1/СЧЁТЕСЛИ(A1:A10;A1:A10);0)).

Предыдущие формулы работали со значениями и текстом. Если диапазон содержит только числовые значения или пустые ячейки (но не текст), можно указать следующую формулу (которая не является формулой массива), чтобы подсчитать количество недублированных значений:
=СУММ(Ч(ЧАСТОТА(A1:A10;A1:A10)>0)).


Top